Friday, June 13, 2014

"Thread stuck in device driver" for Dell with Windows 8.1 - solved

You get "THREAD STUCK IN DEVICE DRIVER" after every sleep / hibernate in Dell Inspiron 15R notebook after upgrading Windows 8 to Windows 8.1. Restoring previous state before sleep was not possible and a restart os Windows was forced. I give the solution, which helped me (copy-past-ed):

I have been reading through many, many forums to have this annoying message disappear. For 3 month I was pulling my hair because of this silly message! I also have a Dell Inspiron 15R and when I turn it on, it showed this blue message saying THREAD STUCK IN DEVICE DRIVER, it then reboots itself followed by 5-10seconds of black screen. This issue only began after I updated from Windows 8 to Windows 8.1. I kept records of what I read through many forums to fix this and hopefully this will work for you.

1. I went to the Dell website and re-installed the BIOS. I believe after upgrading from Win 8 to Win 8.1, the BIOS does get a little messed up. Find out your BIOS version by pressing the Windows key + R, and type msinfo32 then and go to Dell website then reinstall it. In my case, I went to the Dell UK website and reinstalled it.
2. I went to the Intel website and installed the Intel Update Tool below.
3. I uninstalled the AMD drivers which were currently installed via Control Panel, then I restarted the laptop.
4. After logging in, I downloaded the AMD Clean Install Utility from the AMD website below.
5. I then installed the latest AMD Catalyst Suite from the AMD website below. In my case, it’s the 64bit AMD.
6. Finally from the AMD website, I installed the AMD Auto Driver Detector from the below.
7. Back to the Intel website, I clicked on the “Check Your System For Updates” link. This detected all the Intel Drivers and showed me which ones needed updating. In my case, it detected that I needed to download 3 separate drivers.
Finally, I restarted my laptop. I did them all in this order and this worked for me like a charm.

This is solution from J.King Jr which helped me. It is posted here in Microsoft's forum.

The key was to Update BIOS, and after that to make a clean install of ATI driver. I tried to skip some steps of provided how-to, but the issue continue to persist.

No comments:

Post a Comment